+63(32) 495-2106   |   +63(32) 268-6937 apexsinc@apexvalue.com

According to Davis.

There were updates made to the hardware in consoles dated July 2012 and later. If you are using a new console or a recently repaired console with an older data logger, you will get an error “incompatible logger”.

It is not our intention to make you buy new data loggers. If you experience trouble with a new console and your old Davis data logger, please contact us. We will upgrade your old Davis data logger to a new Davis data logger for our standard repair fee.